Site update status: Test site available

FlyingRon

Board of Directors, Webmaster
Ron
Staff member
Corporate Member
Greetings,

I'd like to thank Mike for stepping in and posting the status from the board meeting. I've been heads down trying to figure out this problem for the past two weeks.
Let me explain what's going on.

We need to update the site. The existing site is running a combination of vBulletin 4 and PhotoPost (our image gallery). vBulletin 4 is an older version and has latent security issues which while they've not hit us yet, it is probably a matter of time.
The PhotoPost people have gone out of business (and the support even when they were around was iffy). In addition, the people hosting our site have "upgraded" things that make some of this old software (notably the gallery) not work as well as it used to.

Fortunately, there is a well respected replacement called XenForo. It includes an "media gallery" product. They've just come out with version 2.1 of their software and I've been doing the various things that we need (displaying our ad banners, handline the upcoming raffle, etc).
I thought I'd had the test site up last week, but I came to the realization that there is not currently an upgrade path from PhotoPost to XenForo 2.1 direcltly. You have to go to XenForo 1.5 and then upgrade that to 2.1. This is all well and good except the upgrade takes almost a day of runtime even if it all goes uninterrupted (which of course it didn't). Did you know that we have over 33 Gigabytes of imagery in our galleries?

Well, I finally finished a test site (more on that later). My intent is to leave this up for a few days for test and then if nobody finds any glaring errors, we'll set the existing vB site to READ ONLY mode (just incase there was some content that m issed being transferred) and the new XenForo site will become the new www.ncwoodworker.net. Note that both the new and old sites will be in read only mode for the day or so it takes to transfer from one to the other. Watch here for further announcements of site availalbilty.

What remains to be done (and is not quite as urgent as the rest) is moving over our article system (I only imported the forum posts and the gallery), the chat, and finishing up a few other special NCWW hacks (the DQ system ,etc..).

WHAT YOU CAN DO:

You can try out the new site and let me know if you see any real problems with it. You can PM flyingron on either site or email me at web.master@ncwoodworker.net.
This site has all the content from the existing site as of a few days ago and your username and password from here should get you in there. I do know that there were a few files dropped in the gallery transfer (notably the two open house pictures), that will be resolved on the real upgrade.
Note, that no content you create or upload on the test site will remain after the REAL XenForo site is released so keep a copy of anything important.

Oh, yes, the test site is https://test.ncwoodworker.net
 

Phil S

Board of Directors, President
Phil Soper
Staff member
Corporate Member
OK I am jumping over to try the test site but before I see how well it works I want to say
THANK YOU RON
 

Hmerkle

Hank
Corporate Member
Ron,
A few questions - and I am posting it here so everyone can see your answers.
1. I attempted to log in and it said "Cookies are required to use this site. You must accept them to continue using the site" I am using Chrome and have "Allow sites to save and read cookie data (on) and there is no hyperlink on the alert to change the setting. Am I missing something?
Update - I tried it in IE and was able to log in with no problem...
2. The "Home" screen seems to be a choice of three "jump" buttons (Access NCWW Forum," "Back to the real site," and "PHPMyAdmin (admin only)" in the VB software "home" would display a list of "Posts From Last 15 Days"
Question: when the XenForo software goes live will the Home screen link to "what's new" or will we need to navigate to the "What's New" tab?
3. (may be my settings), but the VB version is the width of my screen at 100%, I have to increase the zoom on the XF version to 125% to "match it"
4. I was not able to "attach pictures" - goign to try a different method... found that a 2,637 KB picture was too large, 1153 KB was too large.
A 970 KB file uploaded - I am guessing files are limited to 1 meg (1000KB), is that right?
5. I like the "like" button, better than the "thanks" button, (probably will until I want to thank someone rather than "like-ing" them sometime in the future! ha ha)

All in all like Mike said, a few things to get used to , but all in all a MUCH needed change and I think it will work better in the long run!
 

Hmerkle

Hank
Corporate Member
This may sound stupid, but somehow the pictures seem to be rendered better in the XF site than VB - is that possible or is my brain playing a trick? ( even tried looking at them on two different monitors, and thought the ZF picture was more "life-like?!"
 

Bryan S

Bryan
Corporate Member
What everyone else has said :icon_thum. While I am one of those who do not adjust to change well, I will figure it out.
 

Hmerkle

Hank
Corporate Member
What everyone else has said :icon_thum. While I am one of those who do not adjust to change well, I will figure it out.
Bryan,
I am a little bit the same - when I learn something (like a dog checking each tree) I keep going back... then I stop and think... Oh, this is different...
please post your struggles as they will help someone else doing the same things and hopefully a work-around!
 

bowman

Board of Directors, Events Director
Neal
Staff member
Corporate Member
It took me a couple of moments to find how to start a new thread, but the new site is a vast improvement. I copied a photo from Google photos directly into the post and had no issues.
 

bowman

Board of Directors, Events Director
Neal
Staff member
Corporate Member
I think there are a few of us that cannot find how to add a photo from the media gallery
 

Hmerkle

Hank
Corporate Member
I think there are a few of us that cannot find how to add a photo from the media gallery
But can you attach a photo from your computer?
(I kind of like that better than, uploading photos to the site and then attaching to a thread)
This way, (if Ron can change the size limitation) you can simply choose a number of pictures and attach them to a thread...
 

SteveColes

Steve
Staff member
Corporate Member
Can’t login. Says bad password. I can’t find a link to reset the password.

Current security ”standard” usually, if there a password or username is to NOT say which it is in the error message.

Also, thank you very much for your work.
 
Last edited:

bowman

Board of Directors, Events Director
Neal
Staff member
Corporate Member
Yes Hank, I can attach a photo from my computer.

I also noticed that Google Photos is not on the list of services allowed to pull images using a url.
 

Hmerkle

Hank
Corporate Member
Yes Hank, I can attach a photo from my computer.

I also noticed that Google Photos is not on the list of services allowed to pull images using a url.
HMMM... maybe that is something Ron should look into as well....
 

Berta

Berta
Corporate Member
I looked at the Calendar. There is not a calendar picker? There is not an event calendar? I think there should be 2 Birthday and everything else. Everything else being the primary. I am not computer savvy. If someone is going to break this, it will be me.
 

Mike Davis

Mike
Corporate Member
I looked at the Calendar. There is not a calendar picker? There is not an event calendar? I think there should be 2 Birthday and everything else. Everything else being the primary. I am not computer savvy. If someone is going to break this, it will be me.
When you create a thread, you have the option to put it in the calendar. Then it automatically makes a notice of the event.

Ron tried it but I haven’t yet.
 

Our Sponsors

LATEST FOR SALE LISTINGS

Top